chiprook
← Software
SoftwareOctober 11, 2026, 08:09

Podman bug: --uidmap container restarts only once on AppArmor hosts

On AppArmor-enabled hosts, a rootful Podman container with its own ID mapping (--uidmap/--gidmap) and a restart policy restarts at most once, then stays exited. The podman container cleanup process fails with "profile containers-default-0.62.2 specified but AppArmor is disabled" even though AppArmor is enabled. Reproduced on Debian 13 with Podman 5.4.2 and upstream on Ubuntu 26.04 with 5.7.0 and 6.1.3.

Podman bug: --uidmap container restarts only once on AppArmor hosts
#Podman#AppArmor#Debian#Ubuntu
Read next
Software

Red Hat Linux is losing its grip on the professional world

Security

Exploit Released for Unpatched Ubuntu Linux Container Escape Flaw

Software

Portainer 3.0 Goes Kubernetes-First, Docker Becomes Secondary

Software

Microsoft explains why restarting Windows can shut it down more completely than shutting it down